Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

Completely new, and completely lost.

Discussion in 'Help & Support' started by WalkerBohh, Jan 1, 2017.

  1. WalkerBohh

    WalkerBohh Delta User

    Ok, so first, like many of you I'm a massive fan of C2's works. I stumbled accross this site when searing for any news relating to the .hack franchise, specifically hoping that there may be a remaster for the ps4, considering that many other popular, yet off the beaten trail, games were given a facelift and update, i.e. Dark Cloud 1 & 2.

    So I'm more than a bit lost as to what The World R: 1 and 2 are, are they mmo's?

    And lastly, I've downloaded R:1, but cannot get the exe to work because it says I am missing file "dx8vb.dll" but it's in the library folder. I've extracted the download file to my desk top. Any and all help is much appreciated.
  2. AzureZhen

    AzureZhen Administrator Staff Member R:Craft Staff

    Here's a quick overview of all the projects hosted here.
    The World R1 - A 2D based MMO being most done by @Tyrial. It's similar to the old The World 2D game that was up from 06-08 by Joe. All you need is a non Google login forum account as Google login accounts are having issues right now and are unsupported.

    The World R2 - A 3D based MMO that will work and look similar to the GU series of the games. It will be for PC (Windows, MacOS, and Linux I do believe) and possibly PS4. Here is where that project is currently at http://forums.cyberconnects2.com/index.php?threads/.609/

    The World RCraft - A Minecraft based version of The World using various mods and server side additions to work just like The World does in the games. I'm currently the lead for this project. You just use your forum account for signing into the launcher instead of needing a Mojang account so ownership of Minecraft is not needed.

    As for your issue, please make sure you are launching with the AlphaLauncher and if you are using AVG please allow an exception in it for the game folder. To do this please follow the instructions HERE

    If you have anymore questions feel free to ask.
  3. WalkerBohh

    WalkerBohh Delta User

    I'm using McAfee, and I'm not sure how to change the clearance for programs on it, but I'm trying to figure it out. Let me just say that this may be the single most comprehensive and helpful reply I've received on a video game message board in my entire life, thank you.

    I was able to add it to t he list, but it still can't run, and the same error message saying that file "dx8vb.dll" is missing. do i need to delete and redownload?
    Last edited: Jan 2, 2017
  4. AzureZhen

    AzureZhen Administrator Staff Member R:Craft Staff

    It wouldn't hurt to redownload but as for further help, let me just tag @Tyrial as he'd have a better understanding of the issue at hand.
  5. WalkerBohh

    WalkerBohh Delta User

    Ok, so yesterday while I was trying to get the program added to my accepted list on McAfee, I had to uninstall and reinstall both the download and McAfee. I just tried running the Alpha program again, and this time McAfee says that a file named artemis is a trojan and wont let me run the program.
  6. Tyrial

    Tyrial Code Whisperer Staff Member R:1 Veteran

    Artemis? We do not have a file named anything similar to that in any of our games, can you post a (cropped) screenshot of that? I'm very interested

    As far as the DLL goes, basically Windows is stupid and can't find it. It needs to be told where the file is. To do this, you need to open command prompt as administrator and type the following commands

    REGSVR32 "<path to dx8vb.dll">
    "C:/Windows/SysWOW64/regsvr32" "<path to dx8vb.dll>"

    example :
    regsvr32 "c:/program files/cyberconnects2/the world alpha/library files/dx8vb.dll"

    The quotes are required because of the spaces in the filepath

    Let me know if it works or not!
  7. Tyrial

    Tyrial Code Whisperer Staff Member R:1 Veteran

    I want to add, that the updater/launcher (AlphaLauncher.exe) should be the program you are launching. after it's fully updated, you will be able to use the "Repair Tool" (from the launcher) and it can register the files automatically for you, while also making sure everything else is correct
  8. Sin

    Sin Delta User

    There he is - TY! Dis white boy ain't easy to get a hold of x.x how come Lios keeps kicking me?! Is he some dirty FudgeBoy?!
  9. EsanChocoCake

    EsanChocoCake Delta User

    Hi
    I have a login problem that it says Account not Found . I have none Google account since u mentioned google accounts have problem but cant login anyway looking forward to see this World 1 xD . I hope when it became complete it can surpass ASURA WRATH .
  10. AzureZhen

    AzureZhen Administrator Staff Member R:Craft Staff

    Please reset your password and test again.

Share This Page